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Writing a Letter of Recommendation

YD Data File:
BA_Project_01_DF.docx

“® Purpose:
One of your best workers is moving to a new city and has asked you to write a letter of
recommendation for her.

“® Procedure:
1. Open a new Word document and set the line spacing for single space.

2. Set the top margin at 1 inch and set the side margins at 1.25 inches.
3. Set the font at 12 pt. Times New Roman.

4. Set the alignment for justified text.

5. Copy and paste the letterhead from data file BA_Project_01_DF.docx.
6. Three lines below the letterhead, key the date. Press Enter four times.

7. Key the name and address of the person who is receiving the letter as shown in Figure 1.1.
Press Enter twice.

8. Key the salutation. Press Enter twice.

9. Key the body of the letter as shown in Figure 1.1. Be sure to double space between paragraphs.
10. After the last line of the letter, press Enter twice.

11. Key the closing.

12. Press Enter four times and key your name and title.

13. Spell Check the letter.

14. Print one copy of the letter and sign it.

15. Save the fi le as Project_01-[first and last name].docx. Close the document.




Figure 1.1

Lena Stoll

The Tweed Courthouse
52 Chambers Street
New York, NY 10007

Dear Miss Stoll:

Mary Cruz has worked at our law firm for the past two years. She is very goal oriented
and has a great desire to complete her tasks on time. Mary is enthusiastic and willing to
ask questions.

Mary works under my supervision as a paralegal. Her responsibilities include conducting
research and interviews, fact checking, writing briels, and working with our lawyers.
Mary has proven to be a hard worker and a talented writer.

| have been quite impressed by Mary’s ability to complete all work assigned to her on
time, if not before it was due. She follows through on all her tasks and does not rely on
anyone else to ensure that the job is done well. She also keeps management informed
every step of the way. She takes responsibility for her actions and is always open to
suggestions or criticism,

Her research is always thorough and comprehensive, and her fact-checking is always
accurate. All of our paralegals do some writing, but Mary’s talents prompted us to assign
her the toughest projects. Her writing is clear, concise, and evocative.

Overall, Mary is a very conscientious and able employee. 1 strongly recommend her for
any midlevel paralegal position. Please call me il you would like to discuss Mary’s talent
and potential any further.

Sincerely,

Your Name
Manager




Category Excellent (4) Proficient (3) Developing (2) Beginning (1) Score
Keying Text Letteris free of | Letterisfreeof | Letter is free of There are five or
typographical typographical typographical more typographical
BIrors. errors, withone | errors, with three | errors.
or two exceptions. | or four exceptions.
Font Font is 12 pt. Font is 12 pt. Fontis 12 pt. Times | Fontis not 12 pt.
Times New Times New New Roman (with | Times New Roman
Roman (withno | Roman (withno | no bold, italicized, | (with no bold,
bold, italicized, or | bold, italicized, or | or underlined text) | italicized, or
underlined text) | underlingd text) | throughout, with | underlined text) in
throughout. throughout, with | two exceptions. three or more cases.
one exception.
Organization and | Letter outline, Letter outline, Letter outline, Letter outline,
Margins margins, ling margins, line margins, ling margins, ling spacing,
spacing, and spacing, and spacing, and and alignment are
alignment are alignment are alignment are exactly as given in the
exactly as given | exactly as given | exactly asgivenin | directions, with three
in the directions. | inthe directions, | the directions, with | or more exceptions.
with one exception. | two exceptions.




Creating an Invitation

YD Data File:
BA_Project_02_DF.docx

‘B Purpose:

Y

our supervisor has asked you to prepare invitations for the retirement party. You have

determined that the best way to distribute the invitation is to place a flyer in every employee’s
mailbox.
YD Procedure:
1. Open a new Word document.
2. Set both the horizontal and vertical alignment to center. Choose Page Layout>Page
Setup>Dialog Box Launcher and select the Layout tab to set the vertical alignment.
3. Choose Page Layout>Page Background>Page Borders. On the Art menu, scroll down to select
the Balloons border.
4. Copy and paste the text from data file BA_Project_02_DF.docx. Keep the same hard returns and
line spaces. Format the following point sizes and font:
a. Come Celebrate the Retirement 24 pt. Comic Sans MS
of Daniel Nelson
b. Tuesday June 2, 2009 16 pt. Comic Sans MS
6:00-10:00 p.m.
Tony’s Restaurant
50 Avenue X
Brooklyn, NY 11223
(718) 555-1234
$50.00 per person includes
Dinner, Dancing, Entertainment, and Gift
c. MENU Bold, 16 pt. Comic Sans MS
5. Format the remainder of the document (the menu) to 10 pt. Comic Sans MS.
6. Bold the titles Beverages, Appetizers, Entrees, and Dessert.
7. Double space between each menu category.
8. Spell Check the invitation and correct any spelling errors.
9. Print one copy.
10. Save the file as BA_Project_02-[first and last name].docx.
11. Close the document.




Category Excellent (4) Praficient (3) Developing (2) Beginning (1) Score
Capitalization Entries are Entries are Entries are Entries are capped,
and Spelling capped, or not capped, or not, capped, or not, or not, as instructed,

(all caps, cap/ as instructed, as instructed, with threa or
lowercase, or with one errarin | with two errors in maore errors in
lowercase only), | capitalization and/ | capitalization and/ | capitalization and/or
as instructed. All | or spelling. or spelling. spelling.

spelling errars

are corrected.

Fonts Entries accurately | Entries accurately | Entries accurately | Most entries do not
reflect font sizes, | reflect font sizes, | reflect font sizes, accurately reflect font
name, and use of | name, and use of | name, and use of sizes, name, and use
bold as given in | bold, with only bald, with two to of bold.
the instructions. | one error. three errors.

Alignment, Document is Document is Document is Document is aligned

Spacing, and aligned both aligned correctly | aligned correctly correctly and all

Use of Borders | horizontally and all entries and all entries entries are spaced as
and vertically. are spaced as are spaced as instructed, with three
All entries instructed, with instructed, with or more excaptions in
are spaced one exception two exceptions in | alignment or spacing.
as instructed. in alignment or alignment and/or No border is present.
Balloon border is | spacing. Balloon | spacing. Balloon
in place. border is in place. | border is in place.




Creating a Memo

Y Data File:

BA_Project_03_DF.docx
BA_Project_03_Template.dotx

Purpose:

An employee of your hotel has been accused of being rude to a guest. Create a memo to all hotel
employees reminding them to treat all guests with equal care and concern for their comfort and
satisfaction during their stay at your hotel.

Procedure:
1. Open the file BA_Project_03_Template.dotx. This file contains a template for a business memo.
2. Key: Excelsior Hotel in the company name section.
3. Set right and left margins to 1.25 inches.
4. Set top margin to 2.0 inches.
5. Complete the heading of the document as shown here, with items on the left in boldface.
To: All Staff Members

From: Your Name, General Manager
CC: Keith Karyn, President

Date: [Today’s date]

Subject: Hospitality

6. Use the justification alignment for the body of the memo.

7. Skip one space below the black line and add the memo text by copying and pasting text from
data file BA_Project_03_DF.docx. Make the memo text single-spaced and change all text under
the Memo heading to 12 pt. Calibri.

8. Italicize the words serious, attentively, and respectfully.

9. Format the text after “Please keep the following in mind” as a bulleted list, with the bullets
aligned under “Please.” The bulleted text should have a hanging indent of 0.3 inches.

10. Spell Check the memo and correct errors.

11. Print one copy.

12. Sign the memo.

13. Save the file as BA_Project_03-[first and last name].docx. Be sure to save the memo as a Word

document, and not as a template.

14. Close the document.




instructed with
bold and italics
added correctly.
All spelling errors
in the text have
been corrected.

or italics are not
added. All spelling
errors corrected.

bold or italics
added, but not
both. All spelling
errars corrected.

maore spelling errors
not corrected.

Category Excellent (4) Proficient (3) Developing (2) Beginning (1) Score
Margins, All margins and All margins are At least one margin | Two or more margins
Alignment, and alignment are set as instructed, | and the alignment and the alignment are
Spacing set exactly as but alignment is are incorrect. incorrect. Memao text

instructed. Memo | incorrect. Memo Memo text is is not single-spaced.
text is single- text is single- single-spaced.
spaced spaced.
Template and The correct The correct The correct Template is incorrect
Bulleted List template has template has been | template has been | or missing. The
been used. The used. The bulleted | used. The bulleted | bulleted list is
bulleted list list has one error | list has two errors | incorrect or missing.
appears exactly in layout {e.g., in layout (e.g., the
as instructed. bullets are not bullets are not lined
lined up under up under “Please,”
“Please” or the and the hanging
hanging indent is | indent is not 0.3
not 0.3 inchas). inches).
Font and Spell Font after Font is changed Font is not changed | Font is not changed
Gheck “Memo” heading | as instructed, in all places where | at all. Bold and italics
is changed as but either bold instructed. Either not added. One or




Creating a Menu

YD Data File:
BA_Project_04_DF.docx

‘B Purpose:
Create a special lunch menu from which your customers will choose a beverage, appetizer, entrée,
and dessert, all for a set price. The menus will be laminated after printing, so check carefully for
errors.

“® Procedure
1. Open the data file BA_Project_04_DF.docx.
2. Save the file as BA_Project_04-[first and last name].docx.
3. Set the vertical alignment to center.
4. Set the horizontal alignment to center.
5. Place the insertion point at the end of the first line. Press Enter twice.
6. Add a single blank line following each of these lines:
a. lunch menu
b. (free refills)
c. potato skins
d. shrimp scampi
e. chocolate mousse cake
7. Make the following formatting changes as indicated.

Text Font and Font Size Style
a. Oceanside Grill 48 pt. Arial Bold, all caps
b. special 16 pt. Times New Roman Bold, all caps
c. lunch menu 16 pt. Times New Roman Bold, double underline, all
caps
d. beverages 14 pt. Times New Roman Bold, all caps
e. appetizers 14 pt. Times New Roman Bold, all caps
f. entrees 14 pt. Times New Roman Bold, all caps
0. desseris 14 pt. Times New Roman Bold, all caps
h. all drink and food items 12 pt. Times New Roman Italics. initial cap on each
word/lowercase
i. $14.95 per person 16 pt. Times New Roman Lowercase
j. Choose one item from 14 pt. Times New Roman Initial cap/lowercase
gach category
k. (15% gratuity charge 10 pt. Times New Roman Lowercase
for parties of 6 or more)




8. Spell Check the menu.
9. Print one copy.
10. Close the document.

Category Excellent (4) Proficient (3) Developing (2) Beginning (1) Score

Fonts Entries accurately | Entries accurately | Entries accurately There are more than
reflect font reflect font sizes, | reflect font sizes, four errors in font
§iZes, names, names, and names, and sizes, names, and
and attributes attributes, with attributes but with attributes.
(e.g., bold, italic, | only one or two three to four errors.
double underline) | errors.
as given in the
instructions.

Capitalization Entries are Entries are Entries are Entries are

and Spelling capped, or not capped, or not, capped, or not, as capped, ar not, as
(all caps, cap/ as instructed, instructed, with instructed, with four
lowercase, or with two errors three errors in or more errors in
lowercase only), | in capitalization capitalization and/ | capitalization and/or

as instructed. All | and/or spelling. or spelling. spelling.
spelling errors
corrected.
Alignment and All entries All entries are All entries are All entries are spaced
Spacing are spaced spaced as spaced as as instructed, and
as instructed. instructed, and instructed, and document is aligned
Document is document is document is bath horizontally and
aligned both aligned both aligned both vertically, with three
horizontally and harizontally and horizontally and or more exceptions.
vertically. vertically, with vertically, with two
one exception. exceptions.




YD Data File:
BA_Project_05_DF.docx

B

Purpose:

You have been asked to create a report about the importance of peer groups during adolescence.

The report will have a header, footer, page numbers, footnotes, and a quotation.

Procedure:

1. Open the data file BA_Project_05_DF.docx.

2. Save the file as BA_Project_05-[first and last name].docx.

3. Set right and left margins to 1.0 inch and the top margin to 1.0 inch.

4. Set the document to double space.

5. Position the insertion point at the top of the document. Press Enter three times.

6. Key the title Adolescent Peer Groups in caps.

7. On the next line, key By [your first and last name].

8. On the next line, key today’s date.

9. Center and bold the title, name, and date lines.

10. Use justified alignment for the body of the report.

11. Change the font to 11 pt. Calibri.

12. In the second paragraph, select the quotation.

a. Single space the quotation.

b. Increase the side margins of the quotation to 1.5 inches.
c. Increase the first line indent of the quotation by 0.5 inch.
d. Delete the quotation marks.

e. Leave one blank line above and below the quotation.

13. Choose Insert>Header & Footer>Page Number. Add a page number to the header. Right align
the page number. The page number should not appear on the first page of the report.
(Page Layout>Page Setup>Dialog Box Launcher, on Layout tab, select Different first page under

Headers and footers.)

14. Use the text at the end of the data file to insert footnotes where shown in the body of the
report.

Note: Numbers should be Arabic numerals.

15. Make certain that the bibliography is on a separate page at the end of the report.

16. Spell Check the report.

17. Print one copy.

18. Close the document.




Category Excellent (4) Proficient (3) Developing (2) Beginning (1) Score
Margins, Margins are set Margins set as Margins set as Margins set as
Alignment, and as instructed. The | instructed; text instructed; text instructed; text
spacing text is justified justified and justified and justified and

and double- double-spaced: double-spaced:; double-spaced:; long
spaced. Long long quotation long quotation quotation is set off,
guotation is set is set off, is set off, single-spaced, and
off with a line single-spaced, single-spaced, indented correctly—
space above and | and indented and indented with three exceptions
below, is single- | correctly—with correctly—with two | for any of the above.
spaced and is one exception for | exceptions for any
indented one-half | any of the above. | of the above.
inch an either
side.
Header Header is set up Header is set up Header is set up as | Header is missing.
as instructed. as instructed, with | instructed, with two
one exception. exceptions.
Footnotes Footnotes, with Footnotes, with Student has No notes are
arabic numbers, | arabic numbers, inserted endnaotes included, or student
are inserted are inserted where | instead of has made three
where instructed. | instructed, with footnotes, with 0r More errors in
one exception. arabic numbers, inserting footnotes.
or student has
made two errars in
inserting footnotes.




B

B

Data File:
BA_Project_06_DF.docx

Purpose:
The brochure will be given to parents who visit the school to learn more about the College Bound
Academy the school offers. The brochure needs to be colorful, easy to read, and informative.

Procedure:

1. Create a new Word document and set the orientation to landscape.

2. Set top and bottom margins to 1.0 inch.

3. Set right and left margins to 0.75 inch.

4. Create three text columns (Page Layout>Page Setup> Columns>Three).

5. Set the alignment to justify for the entire document.

6. Position the insertion point at the beginning of the document.

7. Choose Insert>Text>WordArt.

8. Key: Central High School and click OK. (You will have to resize and reposition the WordArt so

that it will appear at the top of the left column).

9. Create WordArt that says College Bound Academy. Position it directly under Central High
School. Resize as necessary.

10. Insert Clip Art of a microscope (Insert>lllustrations>Clip Art). In the Search for section,
key: microscope and select a microscope picture that you think will complement the brochure.
Position the Clip Art directly below College Bound Academy. Resize as necessary.

11. Delete unnecessary lines after WordArt and Clip Art.

12. Place the insertion point on the first line after the microscope Clip Art. Press Enter once.

13. Copy the text from data file BA_Project_06_DF.docx and paste it at the insertion point.

14. Change the text to 11 pt. Calibri.

15. Make headings and subheadings bold and left aligned.

16. In the second column, the sentence beginning with “We promote . ..” and the following five
sentences should be bulleted, with a hanging indent of 0.25 inch.

17. The brochure should fit on one page. A heading or subheading should not be the last line in a
column.

18. Spell Check the brochure and correct errors.

19. Print one copy.

20. Save and close the document.




Category

Excellent (4)

Proficient (3)

Developing (2)

Beginning (1)

Score

Font and Spell
Check

Text accurately
reflects font

size, name, and
attributes (i.e.,
bold) as given in
the instructions.
All spelling errors
are corrected.

Text accurately
reflects font

size, name, and
attributes, with
only one or

two errars. All
spelling errors are
corrected.

Text accurately
reflects font size,
name, and attribute
but with three to
four errors. All
spelling errors are
corrected.

More than five entries
do not accurately
reflect font sizes,
names, and/or
attributes.

Spelling errors are
not corrected.

Use of Graphics

All graphics are
attractive and
complement one

All graphics are
attractive, but
not all graphics

Graphics do not
fit in the first
column and do not

Graphics do not fit
in the first column
of the newsletter.

and margins set
as instructed.

and/or line spaces
are not set as
instructed.

and/or line spaces
are not set as
instructed.

another (in size, complement one complement one Graphics are
color, style). They | another. They anather. unattractive or
all fit in the first fit in the first missing.
column of the column.
brochure.

Layout Braochure fits Brochure fits Brochure does not | Brochure does not fit
on one page, in on one page, in fit on ane page, on one page, is not
Landscape view, Landscape view, but is in Landscape | in Landscape view,
three columns, three columns, view, with three with three columns.
with line spaces but margins columns. Margins Margins and line

spaces are not set as
instructed.




