
Creating Folders
As you have learned, folders are used to organize files on a disk, and folders are represented

by icons that actually look like file folders. When you want to create a folder to store files, you
first must decide where you want to place the new folder. To create a subfolder, your decision is
in which parent folder the new subfolder will be placed. Remember, this is a creation process, a
building process. You decide where to create or where to build.

In Lesson 1, you created a new folder in the My Documents window. Windows Explorer
gives you the versatility to create and manage files in any location accessible by your computer.
This includes hard disk drives, floppy disks, network drives, and folders on those drives. To cre-
ate a folder in Windows Explorer, select New from the File menu and then click the Folder option

LESSON 5

FILE MANAGEMENT WITH
WINDOWS EXPLORER

OBJECTIVES
Upon completion of this lesson, you should be able to:

n Create folders and subfolders. 

n Recognize and distinguish between different types
of icons. 

n Understand how to run an application or open a
 document file from Windows Explorer.

n Name and rename files and folders.

n Delete folders and restore (undelete) a deleted folder
from the Recycle Bin.

n Manage the display and organization of files.

n Copy, delete, and move files from one folder to
another. 

n Use Disk Cleanup to clear your disk of
unnecessary files.

n Run Disk Defragmenter to make your computer oper-
ate more efficiently.

Estimated Time: 1.5 hours

VOCABULARY

8.3 alias

Application file icons

Copy

Destination

Disk Cleanup

Disk Defragmenter

Document file icons

Extension

Filename

Fragmented files

Move 

Parent folder

Source

Subfolder
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Module  1   Computing Fundamentals 

in the submenu. A New Folder icon (see Figure 5-1) appears in the contents pane. To create a
subfolder, click the folder in the tree pane where you want to place the subfolder (or double-click
the folder in the contents pane), then follow the instructions for creating a folder.

FIGURE 5-1
New Folder icon

Recognizing Different Types of Icons
It helps to identify what you are looking at in the Windows Explorer panes, so let’s take a

moment to learn how to distinguish among the different types of icons used to represent loca-
tions, folders, and files. Location icons are graphic images that clearly represent drives, disks, or
locations such as My Computer (a computer) or My Desktop (a stylized desktop). Folder icons
look like the manila folders used in a filing cabinet, and some folders give a clue to their contents
by including a small image such as a musical note, a picture, or a piece of film.

Working with File Icons
There are two basic kinds of file icons—application file icons and document file icons. Each

has distinguishable characteristics.

Application File Icons
An application file icon starts an application. The

icon may look like a miniature version of the program
icon, or it may look like a miniature window (see
Figure 5-2). In both cases, double-clicking an applica-
tion file icon in the contents pane will start the applica-
tion program.

Computer Concepts
An easy way to start an applica-
tion or open a document from
Windows Explorer is to use the
Open command on the File
menu. Select the icon for the file
you want to open or run in the
contents pane and then choose
Open from the File menu.
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Lesson  5 File Management with Windows Explorer

FIGURE 5-2
Application file icons

Document File Icons
Document file icons share the same distinctive feature: a piece of paper with a superimposed

graphic (see Figure 5-3). When you create a document file, you can associate that file with an
application. For Windows, this means you create a link between a document and an application.
This allows you to open a document file directly—you do not need to open the application first.

FIGURE 5-3
Document file icons

Naming Folders and Files
If you are familiar with DOS or older versions of Windows, you may know that both use a

file-naming convention called 8.3 (pronounced “eight dot three”). The “eight” part means that a
file’s name may be up to eight characters long. The “three” part is an extension (no longer than
three characters) to the name. And the “dot” is the period that separates the 8 from the 3. Neither
spaces nor special characters can be used in the DOS naming system. For example, in the filename
letter.doc, the name is letter, the separator is the standard period, and the extension is doc.

Newer versions of Windows, including Windows XP, allow long names (up to 255 charac-
ters) for folders and files, and they allow spaces, punctuation marks, and most characters in the
names. They allow you to name a folder JL Smith & Company Contract instead of a code name
such as jlscocon.doc. In some cases, extensions are also longer in newer filenames. Examples
include the jpeg extension used for some graphics files, and the html extension, short for hyper-
text markup language, which is used to designate files in a format used for Web pages.

But only application programs designed specifically for Windows 95 and later versions will
permit long filenames. To compensate, Windows (and Windows application programs) assigns a
short filename, called an 8.3 alias. Programs that don’t support long filenames see this 8.3 alias
as the file’s name.

Be extra careful working with programs that don’t recognize long filenames:

n If you copy a folder or file with a long filename to a system that doesn’t support long file-
names, the system will use an 8.3 alias.

n When you open a file that has a long filename in a program that doesn’t recognize long file-
names, the long filename could get lost. 

n Utility programs that back up and restore data and applications may not support long file-
names, and using such programs can destroy the long filenames and the backup files may
not be accessible.

1-3.2.6
1-3.2.7
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Module  1   Computing Fundamentals 

The same naming conventions apply to folder names. When you create a new folder (before
you click anywhere else or press Enter), simply key the folder name. As you key, your folder
name replaces the words New Folder under the folder’s icon. Press Enter to display the new
folder name.

S TEP-BY-STEP 5.1
1. Start Windows if necessary, and then start Windows Explorer.

2. If necessary, change the view to Icons.

3. Your instructor will tell you whether you will use a floppy disk or a specific location on the hard disk
drive to store your practice files.

a. If you are using a floppy disk, verify that your practice disk is in the appropriate floppy drive, then
click the disk’s icon in the tree pane (most likely labeled A: or 31⁄2 floppy).

b. If you are directed to use a location on the hard drive, select the correct drive and folder in the
tree pane.

c. Notice that the drive is now displayed in the Address Bar if it is displayed. (If you do not see the
Address Bar, select it from the Toolbars submenu on the View menu to display it.) Notice also that
there are few or no icons in the contents pane. You haven’t created any folders or files yet, with
the exception of the Hobby file in your Assignments folder, which you may see displayed.

4. Create a new folder called Reports:
a. Click New on the File menu, and then select Folder on the submenu.
b. The New Folder icon—with the name New Folder highlighted—appears in the contents pane. Key

the folder name Reports. Be sure to key upper- and lowercase as shown.
c. Press Enter. You should see a new folder named Reports displayed in the contents pane.

5. Create three subfolders in the Reports folder:
a. Double-click the Reports folder icon in the contents pane to open it. The Reports folder icon and

name are now displayed in the Address Bar. 
b. Click New on the File menu and then select Folder from the submenu. A new folder icon appears.
c. Key the folder name Monthly, and then press Enter.
d. Click anywhere in the display window, except on the newly created folder, to deselect it.

6. Following the instructions in Steps 5b–5d, create two additional subfolders in the Reports folder;
name them Quarterly and Final. Your screen should resemble Figure 5-4. Remain in this screen for
the next Step-by-Step.
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STEP-BY-STEP 5.1 Continued

FIGURE 5-4
Three subfolders in the Reports folder

Renaming a Folder
You may find that after you have used a folder for a time, you need to rename it. This is a

simple process; there are actually four ways to rename a folder:

n Click the folder in the contents pane to select it, press the F2 key, and then key in the new
name in the text box.

n Click the folder to select it, choose Rename from the File menu, and then key the new name
in the text box.

n Right-click the folder name, choose Rename on the shortcut menu, and then key the new
name in the text box. 

n Click the Folders button on the toolbar to access the My Computer tasks bar. Then click the
folder icon to select it, click Rename this folder in the File and Folder Tasks panel, and then
key the new name in the text box.

Notice that other folder maintenance tasks appear in
the File and Folder Tasks panel of the My Computer win-
dow. If no subfolder is selected, the File and Folder Tasks
panel includes only Make a New Folder and Publish this
folder to the Web. (If you are on a network, you may also
see Share this folder.) If a subfolder is selected, the task list
includes folder tasks such as Rename this folder, Move
this folder, and Copy this folder. 

Note
Rename folders with care.
Application programs will not
work if they cannot locate the
folder names for which they are
searching.
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Module  1   Computing Fundamentals 

S TEP-BY-STEP 5.2
1. Click the Up button on the toolbar to close the Reports folder and return to the drive contents

display. 

2. Right-click the Reports folder icon to display the shortcut menu.

3. Click Rename in the shortcut menu.

4. Key the new name Status Reports, and then press Enter. Leave this window open for the next
Step-by-Step.

Deleting a Folder
You can delete a folder in four ways:

n Click the folder to select it and then select Delete from the File menu.

n Click the Folders button on the toolbar, click the folder you want to delete to select it, and
then select Delete this folder from the My Computer File and Folder Tasks panel.

n Click the folder to select it and then press the Delete key.

n Right-click the folder and then select Delete on the shortcut menu.

When you delete a folder or subfolder, you also
delete all the files in it. Use extreme caution, therefore,
before you attempt to delete a folder. To make sure this
is what you really want to do, Windows displays a
Confirm Folder Delete message box (see Figure 5-5).
Windows provides one additional safety net when you
are deleting a folder from a hard disk. Folders deleted
from a hard disk are transferred by default to the
Recycle Bin, from which they can be recovered. But a
folder or a file deleted from a floppy disk is gone—
period. No Recycle Bin is available.

FIGURE 5-5
Confirm Folder Delete message box

Note
My Computer allows you to turn
off the Confirm Folder Delete
message by checking the appro-
priate box in the Recycle Bin
Properties dialog box. To pre-
vent accidents, keep this option
checked.
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Lesson  5 File Management with Windows Explorer

S TEP-BY-STEP 5.3
1. Click the Status Reports folder in the tree pane (or double-click it in the contents pane) to open the

folder and display its subfolders.

2. Delete the Monthly subfolder:
a. Click the Monthly subfolder to select it.
b. Press the Delete key. The Confirm Folder Delete message box appears.
c. Verify that the correct folder name (Monthly) is shown before you click the Yes button. Watch as

Windows graphically illustrates the folder being deleted from the Status Reports folder.

3. Click the Up button on the toolbar until you return to My Computer. 

4. Remain in this window for the next Step-by-Step.

Selecting Files
Windows Explorer permits you to control how your files are organized by allowing you to

move and copy files between disks and folders and to delete files. The first step in performing any
of these functions is to select the files.

You learned in Lesson 5 that you select a single file by clicking it. To select two or more files
that are adjacent to one another, click the first file in the series, press and hold down the Shift key,
and then click the last file in the series, and to select files that are not adjacent, press and hold
down the Ctrl key and then click each of the files. You can select all the files in a folder with the
Select All command on the Edit menu in Explorer.

You can use the scroll bars to move around the display window when selecting files. Don’t
worry if the selected object moves out of view. An object will remain selected until you select
another object or cancel the selection. When you want to cancel all the selections in a window,
click a blank area in the window.

S TEP-BY-STEP 5.4
1. In the Windows Explorer tree pane, click the drive that contains your data files for this lesson.

2. If necessary, scroll the window of the contents pane until the Step5-4 folder is in view, then double-
click it to open it. (You might have to click the Show files or Show the contents of this folder link in
the contents pane first to display the files and folders.)

3. Maximize the window.

4. Select Details view if necessary.

5. Select the first file in the contents pane by clicking it once. (Be careful not to double-click, or you may
open the file.)

6. Select nonadjacent files:
a. Press and hold down Ctrl.
b. Click every other filename you currently see in the window.

1-3.2.6
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STEP-BY-STEP 5.4 Continued

7. Deselect the first selected file by pressing Ctrl and clicking the file’s icon.

8. Deselect all the selected files by clicking once on a clear area in the contents pane. 

9. Select adjacent files:
a. Click the first file in the list.
b. Press and hold down Shift. Then click the tenth file in the listing. All the intervening files will be

selected.

10. Deselect all the selected files by clicking once on a clear area in the contents pane. 

11. Click Select All on the Edit menu to select all the files in the folder.

12. Deselect all the files by clicking once on a clear area in the contents pane. Keep the window open for
the next Step-by-Step.

Copying, Moving, and Deleting Files
One of the key advantages of using Windows is

the ease with which you can copy, delete, or move files
from one location to another. You move or copy files
from a source to a destination. The source is the file to
be copied, and the destination is the location (folder or
disk) where the copied or moved file will then reside.
Whenever you need to move or copy files, both the
source and destination locations should be visible. In
this way, you can see what you are moving or copying
and where it is going. In Windows Explorer, you can
view the source in the contents pane and the destination
in the tree pane, or you can use the My Computer
option to make the source and destination windows visible at the same time by changing the
browsing option in the Folder Options dialog box to Open each folder in its own window.
Folder Options are available from the Tools menu.

Copying Files
When you copy a file, you place a duplicate of the file in a different location and the original file

remains in place. To copy a file to a new location on a different disk, select it. You can select more
than one file to copy using the techniques you learned earlier. You can also select a folder to copy. 

When you copy folders in Windows Explorer, you must hold down the Ctrl key as you drag
the object from its current location and drop it onto its destination; that is, to the folder or drive
where you want to copy it. If you are copying a folder from one window to another in My
Computer, however, you simply drag the object to a new location to make a copy—you do not
need to press any key while you drag to make a copy of the file.

Note
The option to open folders in
their own windows is only avail-
able when you are in the My
Computer screen of Windows
Explorer. Click the Folders but-
ton on the toolbar to close the
tree pane on Windows Explorer
to access the My Computer win-
dow so this option will work.

1-3.2.6
1-3.2.7
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Lesson  5 File Management with Windows Explorer

Moving Files
The moving process is similar to the copying process. When you move a file, however, you

remove it from its original location and place it in the destination location. To move an object to
a new location on a different disk in Windows Explorer, simply select it and drag it to the desti-
nation. In the My Computer screen, you must hold down the Shift key as you drag the file to its
destination to move it without leaving a copy in the source location.

Rather than try to remember when to hold down the Shift or Ctrl key, an alternate method of
moving and copying files is to drag the file using the right mouse button. When the file is dropped in
the destination, a menu appears; you can then click on your preference: Copy Here or Move Here.

If you attempt to copy or move a file to a destination where an identically named file exists,
Windows displays the Confirm File Replace message box, shown in Figure 5-6. Click the Yes but-
ton to replace the existing file; click No to cancel the copy or move.

FIGURE 5-6
Confirm File Replace message box

Take special care when moving, copying, deleting, or renaming files so that a file is not lost.
You may inadvertently move a file to a location or rename a file and then forget the name or
location. Another common error occurs when you rename a file using different application soft-
ware than that used to create the original file, so the file is no longer associated with that original
file and you won’t be able to locate it. You may also find that you can no longer open the
renamed file in either the original or the new application.

Common problems associated with manipulating and working with files include lost files
and file or disk corruption. You can avoid these problems by naming and storing files systemati-
cally, backing up data files regularly, and checking compatibility.

S TEP-BY-STEP 5.5
1. Select Tiles from the View menu.

2. In the tree pane, click the drive where the data files for this lesson are located.

3. Find the Step5-5 folder in the contents pane and double-click the folder to open it.

4. Double-click the Status Reports folder to open it.

5. Double-click the Final folder and locate the 5-5Status Qtr 1 file.
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STEP-BY-STEP 5.5 Continued

6. Find your Assignments folder in the tree pane.

7. Drag the 5-5Status Qtr 1 file from the contents pane to the Assignments folder in the tree pane to
move it to the new location.

8. Click the Assignments folder in the tree pane to open it in the contents pane.

9. You should see the 5-5Status Qtr 1 file, now in the Assignments folder. 

10. Hold down the Ctrl key and drag the 5-5Status Qtr 1 file in the contents pane to the Final subfolder
in the tree pane to make a copy of the file in the new location.

11. Leave this window open for the next Step-by-Step.

Deleting Files
There are several ways to delete a file in Windows Explorer; in fact, all the ways mentioned

earlier that you can use to delete a folder can also be used to delete a file. Select the file and then
press Delete, or right-click to open the shortcut menu and then click Delete to quickly delete a
file. You will see a Confirm File Delete message box when you delete a file, just as you do when
you delete a folder. Click Yes in the dialog box to continue the process of deleting the file.
Remember you can also use the Delete command on the File menu or the Delete this file task on
the My Computer tasks bar to delete a file also.

S TEP-BY-STEP 5.6
1. Click the Assignments folder in the tree pane to display its contents in the contents pane.

2. Locate the 5-5Status Qtr 1 file in the contents pane and right-click on the file to open the shortcut
menu.

3. Click Delete to delete the file. Click Yes to confirm the deletion.

4. Close Windows Explorer.

Restoring a Deleted File
As discussed previously, a file (or folder) deleted from a hard disk goes to the Recycle Bin.

The Recycle Bin acts as a temporary storage folder for files you delete and keeps track of where
deleted files and folders were originally stored. Then if you need to recover a deleted file or
folder, you can use the Recycle Bin to restore it to its original location on the hard disk.

To restore a deleted file from the Recycle Bin, you must restore it before you empty the Recycle
Bin because emptying the Recycle Bin permanently deletes all the files currently in the Recycle Bin.
Double-click the Recycle Bin icon on the desktop or click the Recycle Bin icon in the tree pane of
Windows Explorer to open the Recycle Bin window (see Figure 5-7), which displays files deleted
from the hard disk. To restore a file or folder, right-click it and choose Restore from the shortcut
menu, or select one or more items you want to restore, right-click any selected item, and then
select Restore the selected items from the Recycle Bin Tasks panel or Restore from the File menu.

M1L10 C5338 33912_1M 10 Lesson C5338 33912  27/04/2010  09:24  Page 186

98

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight



Lesson  5 File Management with Windows Explorer

The selected file will be returned to its original location
and it will no longer appear within the Recycle Bin. Use
the Restore all items option on the tasks panel to
restore all the files and folders in the Recycle Bin to
their original locations.

FIGURE 5-7
Recycle Bin window

Computer Concepts
If you choose to Empty the
Recycle Bin, the files are perma-
nently deleted and cannot be
restored.

PROJECT MANAGEMENT

Project management is one of the components that a system analyst, a job
described in an earlier lesson, might find in a job description. However, because the
job of a system analyst can sometimes be so detailed, many companies hire a project
manager to work with the analyst and other team members. A project manager might
be in charge of a wide array of projects—from Web site development to implementing
an entire new computer system. The responsibilities of the project manager would be
to manage, guide, keep everyone on task, and coach the team.

People who work in this profession need strong leadership abilities and good orga-
nizational skills. Many people use a management software program such as Project
Management to help them with this job. Educational requirements vary depending on
the company and job requirements—some employers may require a two-year degree,
whereas others require a master’s degree.

Working in a Connected World
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Managing a Hard Drive
A trouble-free hard disk is extremely important to the Windows operating system. Windows

uses your hard disk for temporary storage, and many Windows application programs create tem-
porary files on the hard disk as you use the application. If your hard disk is not in good working
order, you may find your system slow in responding or you may have problems running programs
and opening documents. Hard disks continue to increase in storage capacity, but a disk on a com-
puter that is used by more than one person or for a long period of time may have many files that
are not needed. You can regain disk space using system tools designed to purge the hard disk of
unneeded files.

Windows comes with a number of tools to keep your system in good working order. You
can review all of these by looking up information about system tools in the Windows Help and
Support feature. For the remainder of this lesson, we’ll discuss two important disk maintenance
tools: Disk Cleanup and Disk Defragmenter. You can open both of these programs from the
Start menu.

Disk Cleanup enables you to clear your disk of unnecessary files. Disk Defragmenter
rearranges the files on your disk, repositioning the files in one place so the disk performs opti-
mally. An error-checking tool that reads a disk’s vital signs and either warns you about problems
or fixes them is also available. You can access this tool from Windows Explorer by selecting My
Computer in the tree pane, and then selecting the icon for the disk you want to check. Click on
Properties in the File menu to open the Properties dialog box and you will find the error-check-
ing tool on the Tools tab.

Locating and Deleting Unnecessary Files
You can use Disk Cleanup to help free up space on your hard drive. Disk Cleanup will not

work on floppy drives or CD-ROM disks. The Disk Cleanup program searches your drive and
then shows you temporary files and unnecessary program files you can safely delete. You can
direct Disk Cleanup to delete some or all of those files.

S TEP-BY-STEP 5.7
1. Open the Start menu.

2. Select the All Programs option, select the Accessories option, choose the System Tools option, and
then select the Disk Cleanup option. The Disk Cleanup message box appears showing the progress
of the scan of your hard drive. Note: If your computer has more than one drive, there will be a prompt
asking which drive you want to clean up.

1-3.2.7
1-3.2.8
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STEP-BY-STEP 5.7 Continued

3. When the scan of the hard drive is complete, the Disk Cleanup for (C:) (or the drive selected) dialog
box indicates how much disk space you can gain by cleaning up the disk (see Figure 5-8).

FIGURE 5-8
Disk Cleanup dialog box

4. Only certain file types are selected for deletion by default. Scroll through the list of files to see what
other files could be deleted and how much space could be gained on the hard drive by their deletion.
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STEP-BY-STEP 5.7 Continued

5. Click the More Options tab in the Disk Cleanup dialog box. You will see you have three additional
options for cleaning up your disk (see Figure 5-9). The Windows components option permits you to
remove optional Windows program components you do not use. The Installed programs option per-
mits you to remove programs you may no longer need or use. The System Restore option tracks
changes to your computer and creates a restore point when it detects the beginning of a change. It
permits you to remove all but the most recently saved system restoration point or to restore your
computer to an earlier state in which your computer was functioning the way you liked. 

FIGURE 5-9
Additional disk cleanup options

6. Click the Cancel button to close Disk Cleanup without performing any actions.

Each option on the More Options tab launches a separate program to perform the actions
described. You would need to select each of these options independently. If you wanted to actu-
ally clean up the hard drive on your system (deleting the files listed on the Disk Cleanup tab), you
would click OK in the Disk Cleanup dialog box. A message box would ask you to verify that you
wanted to perform this action—in which case you would click OK. Then the disk cleanup would
proceed. Depending on the number of files involved, the speed of your system, and so on, a disk
cleanup can take anywhere from just a couple of minutes up to a half an hour or more.

Defragmenting a Disk
Disks—both hard and floppy—store data in clusters, also referred to as allocation units. A

cluster is the smallest amount of disk space the operating system can handle when it writes or
reads a file and is usually equal to 512 bytes or the default size of the disk. When you store files
on a newly formatted disk, Windows writes each file’s data in adjacent clusters. For example, the
data for the first file saved might be stored in clusters 3 through 15, the next file’s data might use
clusters 16 through 30, and a third file’s data might use clusters 31 and 32. In this way, Windows
stores data in contiguous clusters; that is, in clusters that are adjacent on the disk.
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Each time you delete a file, however, you empty clusters and make them available for new
data. To optimize your disk space, Windows uses these now-empty clusters as you save new files.
First, Windows saves as much data as possible in the first available cluster, then the next avail-
able cluster, and the next, and so on, until it has stored all the remaining file data. In this way,
Windows splits file data among clusters that are not contiguous. In other words, in its efforts to
optimize disk space, Windows creates fragmented files, files that are not stored in contiguous
clusters. In the normal process of saving new files and deleting old files, your disk becomes quite
fragmented.

Fragmentation does not harm a disk, but heavy fragmentation can slow down the disk’s read
and write times, thus reducing disk efficiency. To enhance disk performance, use Windows’ Disk
Defragmenter (another option on the System Tools submenu, accessed from the Accessories
option on the Start Menu) or a similar program. Disk Defragmenter rearranges disk files, storing
each file in contiguous blocks.

First, Defragmenter looks at your disk and tells you what percentage of the disk is fragmented.
If the disk is not heavily fragmented, you may not want to proceed; in that case, the Defragmenter
gives you an option: continue or quit. If you continue, Disk Defragmenter begins to reposition the
files. While Defragmenter is working, you can click the Show Details button to see a graphic dis-
play of the program’s progress. Note that you cannot use Disk Defragmenter on floppy disks.

S TEP-BY-STEP 5.8
1. Open the Start menu.

2. Select the All Programs option, select the Accessories option, choose the System Tools option,
and then select the Disk Defragmenter option. The Disk Defragmenter dialog box appears (see
Figure 5-10). 

FIGURE 5-10
Disk Defragmenter dialog box
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Module  1   Computing Fundamentals 

STEP-BY-STEP 5.8 Continued

3. Select your hard disk in the list near the top of the window, and then click the Analyze button. Be
patient; it may take Windows a minute or two to analyze the disk.

4. A message box like that shown in Figure 5-11 appears, indicating that the analysis is complete.

FIGURE 5-11
Defragmenter message box

5. Click View Report. The Analysis Report dialog box opens, as shown in Figure 5-12.

FIGURE 5-12
Analysis Report dialog box

6. Click Close to close the report window.

7. If you have permission from your instructor to run Disk Defragmenter, click the Defragment button.
Otherwise, proceed to step 8. 

8. Click the Close button to close the Disk Defragmenter. If you are using a floppy disk as your practice
disk, remove it from the floppy disk drive. If instructed, shut down Windows and turn off your computer.
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SUMMARY

In this lesson, you learned:

n Folders are used to organize files on a disk. Subfolders can be created within parent folders
to build a hierarchy of folders for optimal file organization.

n An application file icon may look like a miniature version of the program icon, or it may
look like a miniature window. 

n It is easy to run an application or open a document file from Windows Explorer by double-
clicking an icon. 

n A document file icon looks like a piece of paper with a graphic on it. You can open an asso-
ciated document file from Windows Explorer without opening the application first.

n You can assign descriptive names up to 255 characters long to folders and files; however,
only Windows 95 and higher can accommodate long filenames. Windows will assign a short
filename, called an alias, to each of these files so they can be used with programs that don’t
support long filenames.

n You can easily rename folders.

n Files are moved or copied from a source to a destination. The source is the file to be copied,
and the destination is the location (folder or disk) where the moved or copied file will be
placed.

n When you copy a file, you duplicate the original. When you move a file, it is removed from
its original location and placed in a new location. 

n Deleting a folder or subfolder deletes all the files within the folder as well. Folders deleted
from a hard disk are transferred to the Recycle Bin. Folders deleted from a floppy disk are
deleted permanently.

n You can restore a deleted folder from the Recycle Bin with the Restore this item option on
the Recycle Bin Tasks panel or File menu.

n You can use Disk Cleanup to clear your hard disk of unnecessary files.

n Disk Defragmenter rearranges the files on a hard disk so the disk performs optimally.

VOCABULARYReview

Define the following terms:
8.3 alias
Application file icons
Copy
Destination
Disk Cleanup

Disk Defragmenter
Document file icons
Extension
Filename
Fragmented files

Move 
Parent folder
Source
Subfolder
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REVIEWQuestions

TRUE/FALSE

Circle T if the statement is true or F if the statement is false.

T F 1. A single cluster is the smallest amount of space on a disk that the operating system
can handle when storing data.

T F 2. You can copy a file in both Windows Explorer and My Computer by holding
down the Shift key as you drag the file from its source to its destination.

T F 3. All application programs can recognize long filenames.

T F 4. Folders deleted from the hard disk can be retrieved from the Recycle Bin.

T F 5. You cannot run an application program directly from Windows Explorer.

MULTIPLE CHOICE

Circle the best response for each of the following statements.

1. The is the original location of the file you are moving.
A. destination
B. source
C. recycled
D. parent

2. In file organization, a subfolder is created within a folder.
A. manila
B. source
C. parent
D. destination

3. A long filename cannot exceed characters.
A. 8
B. 255
C. 88
D. 150

4. The Windows program that enables you to clear your disk of unnecessary files is
called .
A. Desktop
B. Disk Defragmenter
C. Disk Cleanup
D. Disk Check

5. Removing a file from its original location and placing it in a new location is called
a file.

A. moving
B. deleting
C. restoring
D. copying
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PROJECTS
PROJECT 5-1

1. Start Windows if it is not already running, and open Windows Explorer.

2. Copy the Project 5-1 folder from the data files to the Desktop location:
A. Double-click the disk and/or folder containing the data files to display the subfolders in

this lesson’s data folder in the contents pane.
B. Locate the Desktop icon in the tree pane (you may need to scroll up to see it).
C. Hold down the Ctrl key and drag the Project 5-1 folder in the contents pane to the

Desktop location on the tree pane.

3. Move the Project 5-1 folder to your practice disk or folder:
A. Insert your practice disk in the floppy drive or locate your practice folder on the

hard drive.
B. Drag the Project 5-1 folder from the contents pane to the floppy disk drive icon or your

practice folder on the tree pane.

4. Open the Project 5-1 folder in your practice folder (or on your practice disk), and do the
following:
A. Add a new subfolder called Special Report #1.
B. Copy all the files in the Project 5-1 folder with the words Sales Manual in their file-

names to the Special Report #1 subfolder.
C. In the Special Report #1 subfolder, rename the files that contain the word Chapter in

their filenames by changing the word Chapter to Part.
D. Add a new subfolder to the Project 5-1 folder called Quarterly Reports.
E. Move the Progress Reports (Q 1, Q 2, Q 3, and Q 4) files from the Progress Reports

subfolder to the Quarterly Reports subfolder.
F. Delete the Progress Reports subfolder. 

5. Leave this window open for the next project.

PROJECT 5-2

1. Open the Special Report #1 folder from your practice disk or folder.

2. Change the view to Icons.

3. Double-click the Sales Manual Summary file icon in the contents pane to open the file in its
associated application.

4. Close the Sales Manual Summary file and the application window.

5. Click My Documents in the tree pane.

6. Double-click the Internet Explorer icon in the contents pane to run the program. You may
see a message that says the page cannot be displayed because there is not an Internet server
available, or if your computer does have an active Internet connection, you will see the
default home page.

7. Close the Internet Explorer window and then close Windows Explorer.

8. If instructed to do so, shut down Windows XP and your computer.
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TEAMWORK PROJECT

The computers in your office are used to track building repair projects that last from a few
weeks to a few months, and when a project is finished, many files are deleted from the hard
disks. Some workers have noticed that their computers seem to be operating more slowly, and
they wonder if it would be a good idea to use the Disk Defragmenter program on a regular sched-
ule. You and a coworker have decided to survey other PC users whose usage could be described
as heavy and ask whether they use Disk Defragmenter on their computers. Survey at least two PC
users each and then compare your findings. Together, write a written report that summarizes
your findings and conclusions. Discuss why it is a good idea (or not) to schedule using Disk
Defragmenter regularly. Use the Windows Help and Support feature and online resources if nec-
essary to find out more about defragmenting a hard disk.

CRITICALThinking

ACTIVITY 5-1

Design a folder structure to organize files you might create for one of the following: your
home organization, your job environment, your volunteer work. Create a parent folder and at
least two more levels, with at least two folders in each level under one parent. Outline the struc-
ture within your practice folder or on your practice disk.
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