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n	 OBJECTIVES
Upon completion of this lesson, you should be able to:

n	 Create a new document.

n	 Change Word settings.

n	 Enter text in a document.

n	 Change views and magnification in the document window.

n	 Show nonprinting characters in a document.

n	 Use the click and type feature.

n	 Navigate through a document.

n	 Data Files
To complete this lesson, you will need these data files:

Step7-4.docx

Project7-2.docx

Project7-3.docx

Lesson 7

Getting Started with 
Word Essentials

n	 VOCABULARY
default settings

Normal.dotm template

toggle

word wrap

135



	 Module 2  Key Applications

Word is a powerful, full-featured word-processing application. You can use 
Word to create reports, tables, letters, memos, Web pages, and much more. The Word 
lessons in this course will introduce you to features that enable you to prepare docu-
ments efficiently. You will also learn how to change the way the document looks on 
the screen and how to navigate through a document.

Creating a New Document 
When you first start the Word application, a new blank document appears and is auto-
matically titled Document1. The blank document is formatted with default settings, 
which are the preset options or variables automatically in effect when the document 
is created. The default settings for Word are stored in the Normal.dotm template, 
a file containing default styles and customizations that determine the structure and 
page layout of a document. Using the Normal.dotm template greatly increases the 
speed and efficiency of your work since you do not need to spend time setting up the 
details of the page. Information about overriding the default settings and changing 
document formats is provided in Lesson 13.

As you already know, you can open additional documents on top of Document1. 
All new blank document filenames will be numbered sequentially during the session 
that Word is open. The filenames for each open document stay the same until you 
assign a new filename. When the Word application is closed and then reopened, the 
new blank document filenames begin again with Document1.

Step-by-Step 7.1
	 1.	 Start the Word application.

	 2.	 Click the Office Button and then click New to display the New Document 

dialog box shown in Figure 7–1. The options in the dialog box will 

vary, but you should see the Blank document icon, and it should be 

highlighted. Because it’s a blank document, there’s nothing to show in 

the preview pane.

Blank
document
icon

Click to create
a new
document

Preview pane

2-1.2.1
◗  Vocabulary
default settings

Normal.dotm template

Figure 7–1 
The New Document  
dialog box
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Lesson 7 G etting Started with Word Essentials	

	 3.	 Double-click the Blank document icon, or click Create. A new document 

based on the Normal.dotm template opens. Notice that the document 

title bar shows Document2. (If Word was already started when you  

began this exercise, the document number might be higher than the 

number 2.)

	 4.	 Leave the document open.

Changing Word Settings
As you work with Word, you will begin to recognize “behind the scenes” application 
settings that are designed to protect your work and improve your efficiency. If you’ve 
ever experienced your computer locking up or shutting down while you are work-
ing with a document, you know that when you restart an application, one or more 
of your documents may be recovered. This is because there is a setting to schedule 
an automatic save of the document information as you work with the document. You 
can easily customize a setting like this to fit your preferences and meet your needs.

Step-by-Step 7.2
	 1.	 Click the Office Button.

	 2.	 Click Word Options. The Word Options dialog box shown in Figure 7–2 

will open.

Click to show
the Save
settings

2-1.1.7
2-1.2.4

Figure 7–2 
The Word Options  
dialog box
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	 Module 2  Key Applications

	 3.	 Click the Save option in the list on the left side of the dialog box to 

review the Save settings, as shown in Figure 7–3.

AutoRecover
schedule

File format

Default file
location

	 4.	 Make a note of the file format that is currently selected under Save docu-

ments. The default settings in Word 2007 provide that the document is 

saved in the new XML format (.docx). Click the Save files in this format 

list arrow to view the available settings, but do not make any changes.

	 5.	 Notice that there is a setting for saving AutoRecover information. The 

default setting is every ten minutes, but your setting may be different. 

Do not make any changes to this setting.

	 6.	 Make note of the Default file location box. To change this setting, you 

would click Browse and identify a new path. Do not make any changes 

to this setting.

	 7.	 Click Cancel so that no changes are made to any of the settings.

	 8.	 Leave the document open.

Entering Text in a Document
As you enter text in a Word document, the insertion point moves to the right and 
the page number in the status bar at the bottom of the document window changes 
to reflect the current position of the insertion point. The information in the status 
bar also continually changes to show the current total number of words in the 
document. As you add text to the document, you may see a red or green wavy line  

Figure 7–3 
Save settings in the  
Word Options dialog box 

2-1.3.1

Extra for Experts

Users of previous versions of Word 
are unable to open files saved in 
the new format, unless they have 
installed compatibility software. 
If you often share your documents 
with users working with previ-
ous versions of Word, you should 
consider changing the file format 
setting so that all files are saved in 
the Word 97-2003 (*.doc) format. 
The drawback to this is that some 
of the new Word 2007 features 
that you used and applied in  
the document can no longer  
be accessed. 

138

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight

enas.altarawneh
Highlight



Lesson 7 G etting Started with Word Essentials	

under some of the words. Word automatically checks the spelling and grammar in 
a document as you are entering the text, and the wavy lines suggest there may be 
spelling or grammar errors. If you see any wavy lines while entering text in this 
lesson, just ignore them. You will learn more about the spelling and grammar features 
in Lesson 13.

If the text you are entering extends beyond the right margin, Word will 
automatically wrap the text to the next line. This feature is called word wrap. When 
you press Enter to start a new line in the document, you create a new paragraph. In a 
document based on the Normal.dotm template, Word automatically adds extra space 
after each paragraph, so you need to press the Enter key only once.

Step-by-Step 7.3
	 1.	 If necessary, click the Word button on the taskbar to make Document2 

the active document.

	 2.	 Press Tab, and then enter the sentence below. Notice as you enter 

the text that the insertion point moves and the status bar reflects the 

number of words in the document. Remember: Do not press Enter when 

the text expands to the right side of the screen.

Today, the majority of the American population 
lives in cities and suburbs. The people who live in 
metropolitan areas depend on parks and recreational 
paths close to their homes for both recreation and 
contact with nature.

	 3.	 Press Enter to start a new paragraph.

	 4.	 Press Tab and then enter the sentence below.

To preserve acres of green open space, parks 
surrounding and running through metropolitan areas 
are interconnected to create greenways. Sometimes 
these greenways even link cities together.

	 5.	 Click the Office Button and then click Save As. The Save As dialog box 

will open. Compare the folder structure at the top of the dialog box to 

the default file location setting. They may not be the same because the 

path will show the last folder into which a Word file was saved.

	 6.	 Locate the folder where you are to save your documents. (Your instructor 

will provide this information.)

	 7.	 In the File name box, enter Greenways1, and then click Save.

	 8.	 Check the word count in the status bar at the bottom-left corner of the 

window. The word count should be 62.

	 9.	 Leave the document open.

◗  Vocabulary
word wrap
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Changing Views and Magnification
Changing the way the document looks on your screen can make working with the 
document much easier. You can change the way you view your document, and you 
can also control how much of the document shows on the screen. The appearance of 
the document on the screen should be appropriate for the current task.

Viewing a Document
Word offers different options for viewing a document, and you can change the view 
by selecting options from the Document Views group on the View tab, shown in 
Figure 7–4. You can also change the view by clicking one of the view buttons in the 
status bar at the lower-right corner of the document window, shown in Figure 7–5.

Active
view is
highlighted

Options for
viewing a
document

Figure 7–4  The Document Views group on the View tab

Print Layout
view button

Full Screen
Reading
view button

Web Layout
view button

Draft view
button

Outline view
button

Figure 7–5  View buttons in the status bar

Each view provides a different way to look at and work with a document.  
Table 7–1 describes each of the views. As you work with documents in the different 
views, you may find that you prefer one view for certain tasks and another view for 
other tasks.

2-1.1.5
2-1.1.6
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Lesson 7 G etting Started with Word Essentials	

VIEW DESCRIPTION

 Print Layout

The document shows on the screen as it will appear when printed; this 
is the default view in Word

 Full Screen Reading

The screen space is maximized for reading the document; when two 
pages are shown side by side in Full Screen Reading view, it appears 
as though you are reading a book

 Web Layout

The document shows on the screen as it will appear in a Web browser

 Outline

The document content shows on the screen in an outline format, which 
makes it easy to see the structure of the document and to quickly and 
easily reorganize the content

 Draft

Only the basic document, without elements such as headers and  
footers, shows on the screen; the purpose of Draft view is to make  
the editing process quicker

table 7–1  View options for Word

 Step-by-Step 7.4
	 1.	 Open Step7-4.docx from the data files, and save the document as Ruts.

	 2.	 Click the View tab on the Ribbon. Notice that the document opened in 

Print Layout view.

	 3.	 Click the Full Screen Reading button in the Document Views group on 

the View tab. Your screen should look similar to Figure 7–6. Notice that 

the Ribbon, the scroll bars, and the status bar are hidden.

Figure 7–6 
The document in Full Screen  
Reading view
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	 Module 2  Key Applications

	 4.	 If your screen does not show two pages side by side, click View Options 

in the upper-right corner of the screen and then click Show Two 

Pages.  Your screen should now show two pages side by side.

	 5.	 Click View Options. If the Allow Typing button  is already highlighted, 

as shown in Figure 7–7, the option is already selected, and you can click 

View Options again to close the menu. If the Allow Typing button is not 

highlighted, click the button to select it. Selecting this option will enable 

you to edit the document in Full Screen Reading view.

Orange highlight
indicates the option
is selected

	 6.	 To scroll through the pages in the document, do one of the following:

	 a.	 Press the up and down arrow keys   or the PageUp and 

PageDown keys.

	 b.	 Click the arrows that appear at the lower corners of the pages.

	 c.	 Move the wheel on the mouse.

	 7.	 Show the first page of the document, and position the insertion point 

in front of the letter T in the document title. Enter the words GETTING 

THROUGH so the revised title reads GETTING THROUGH THE RUTS.

	 8.	 Click the Save button in the upper-left corner to quickly save the 

changes.

	 9.	 Click Close in the upper-right corner of the screen to close Full Screen 

Reading view. Your document now appears again in Print Layout view, 

the view that was used before Full Screen Reading view. Notice that the 

words you added to the title are still there.

Figure 7–7 
The View Options menu in 
Full Screen Reading view

Heads up

If the Research task pane appears 
when you change views, close the 
task pane.
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Lesson 7 G etting Started with Word Essentials	

	10.	 Click the Web Layout button. You will most likely notice a difference in 

the width of the document and changes to the text wrapping.

	11.	 Click the Outline button. Notice the Ribbon changes and provides many 

new tools for navigating and editing the outline. You will have an oppor-

tunity to work in Outline view in Lesson 16.

	12.	 In the Close group, click the Close Outline View button. The document 

returns to Print Layout view, with the Home tab active.

	13.	 Click the View tab and then click the Draft button in the Document 

Views group. You will probably notice a change in the magnification. 

Change back to Print Layout view.

	14.	 Leave the document open.

Changing the Zoom and Magnification Settings
Word also provides zoom options to increase and decrease the size of text and 
graphics on the screen, and you can also show an entire page or multiple pages at  
the same time. The zoom options are in the Zoom group on the View tab shown 
in Figure 7–8. You will also find zoom controls in the status bar at the lower-right 
corner of the screen, as shown in Figure 7–9.

Change text size
and magnification

Zoom button

Figure 7–8  The Zoom group on the View tab

Figure 7–9  Zoom controls in the status bar

Step-by-Step 7.5
	 1.	 If necessary, open the Ruts document from your solution files.

Extra for Experts

If your mouse has a wheel, you can 
press and hold Ctrl and move the 
wheel away from you to increase 
the magnification and move the 
wheel toward you to decrease the 
magnification. 
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	 Module 2  Key Applications

Screen preview Text preview

	 3.	 Notice that the current setting is Page width. Make a note of the 

percent. Click to select the 75% option and preview that setting.

	 4.	 Click to select the Whole page option. Notice that the percentage 

changes again.

	 5.	 Click to select the Many pages option. The percentage will change to 

10% and you will be able to view all the pages in the document at the 

same time.

	 6.	 Click OK to accept the change. All four pages of the document will 

appear on your screen.

	 7.	 Click the Page Width button  in the Zoom group on the View 

tab. The first page of the document should appear on your screen.

	 8. 	 Leave the document open.

Showing Characters
As you have learned, changing the way a document looks on the screen can make 
tasks easier. To make editing a document easier, you can also show some special 
characters. These characters are known as nonprinting characters because, although 
you can show these symbols on the screen, they do not print.

The Show/Hide ¶ button, in the Paragraph group on the Home tab, enables 
you to toggle the option to show these nonprinting characters. When you toggle an 
option, you alternate between the off and on states by repeating a procedure, such as 
clicking a button. Nonprinting characters include paragraph markers, blank spaces, 
page or section breaks, and tab markers, as shown in Figure 7–11. Initially, you may 
not like showing nonprinting characters while you work with a document, but give it 
a try. Once you get used to seeing the nonprinting characters on the screen, you will 
find them very useful as you create and edit the document.

Figure 7–10 
The Zoom dialog box

2-2.1.6

◗  Vocabulary
toggle

	 2.	 On the View tab, in the Zoom group, click the Zoom button to open the 

Zoom dialog box shown in Figure 7–10. The Zoom dialog box provides a 

Preview screen and a text preview panel in the Zoom dialog box so you can 

preview how the changes you select will show on the screen.
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Lesson 7 G etting Started with Word Essentials	

Tab markers

Space
symbols

Paragraph
marker
indicates a
line break

Figure 7–11  A document with nonprinting characters showing

Step-by-Step 7.6
	 1.	 If necessary, open the Greenways1 document from your solution files. 

Save the document Greenways1 as Greenways2.

	 2.	 Click the Home tab. In the Paragraph group, click the Show/Hide¶ 

button  to toggle the feature on. The button will have an orange 

background when it is activated.

	 3.	 Compare your document to Figure 7–11. The nonprinting symbols are 

identified in the figure. If necessary, scroll up in the document to see 

the symbols. If you do not see the nonprinting characters on your screen, 

click the Home tab and then click the Show/Hide ¶ button again.

	 4.	 Leave the document open.

Using Click and Type
Click and type is a Word setting that enables you to quickly position the insertion 
point within a blank area of a document. When you double-click in a blank space 
in the document, Word automatically adds blank paragraphs or tabs to position the 
insertion point where you click. Showing the nonprinting characters can be very 
helpful when using click and type. If the nonprinting characters are visible when 
you reposition the insertion point in a blank area of the document, new nonprinting 
paragraph markers and tab markers will appear so you will know how many blank 
paragraphs or tabs were created to move the insertion point to the new location.

2-1.3.1
2-2.1.6
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	 Module 2  Key Applications

Step-by-Step 7.7
	 1.	 If necessary, open the Greenways2 document from your solution files.

	 2.	 Make sure that the click and type setting is enabled. Click the Office 

Button, click Word Options, and then click Advanced. At the bottom of 

the list below Editing options, make sure there is a check mark in the 

box for Enable click and type. The option is turned on when there is a 

check mark in the check box, as shown in Figure 7–12.

Enable click
and type

	 3.	 Click OK to apply the option and close the dialog box.

	 4.	 If necessary, click the Print Layout button  in the status bar to switch 

to Print Layout view.

	 5.	 Use the scroll bar to move to the bottom of the document. All or most of 

the document window will be white. Point to the middle of the document 

window. The mouse pointer will change to an I-beam, indicating text can be 

entered in that area of the document. The I-beam is shown in Figure 7–13.

Insertion
point

I-beam
pointer

Figure 7–12 
Advanced settings in the  
Word Options dialog box

Figure 7–13 
The I-beam in a blank  
area of the document

Extra for Experts

If a graphic is visible next to the 
I-beam, it indicates the format for 
the text. For example, the I-beam 
shown in Figure 7–13 indicates 
that the text will be aligned at the 
left, beginning where you position 
the insertion point. 
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Lesson 7 G etting Started with Word Essentials	

	 6.	 With the mouse pointer positioned in the white area, double-click. 

The insertion point is now positioned where you clicked. Several new 

paragraph markers and a tab marker will appear above and before the 

new location of the insertion point.

	 7.	 Enter your first and last names.

	 8.	 Click the Save button on the Quick Access Toolbar and close the 

document.

Navigating Through the Document
It’s easy to move around in a one-page document, but if the document is several pages 
in length, it takes much longer to navigate. There are several ways to move around 
in Word, including changing the view, using the mouse, and using the keyboard. For 
both short and long documents, there are many ways to save time moving through  
a document.

Using Thumbnails
You’ve already learned about several ways to view a document, but there’s another 
option on the View tab that you have not yet explored. When the Thumbnails check 
box in the Show/Hide group on the View tab is checked as shown in Figure 7–14, 
thumbnails for each page in the document will show in a pane on the left side of the 
document. Figure 7–14 shows thumbnails for the first three pages of a four-page 
document. Each thumbnail is identified with a page number, and the current page 
is also identified in the status bar. Although most words may be too small to read 
on a thumbnail, usually graphics or headings will help you identify the page. To go 
directly to a specific page, click on the thumbnail for that page.

Thumbnails
pane

Page number

Enabled
when the
check box
is checked

Figure 7–14  The Thumbnails pane

2-1.1.3
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	 Module 2  Key Applications

Step-by-Step 7.8
	 1.	 If necessary, open the Ruts document from your solution files.

	 2.	 On the View tab, click to select the Thumbnails check box  

in the Show/Hide group. Four thumbnails will appear in a task pane at 

the left side of the document.

	 3.	 Click the thumbnail for page 3 in the task pane.

	 4.	 Click the Thumbnails check box on the View tab to deselect the option 

and hide the Thumbnails task pane.

	 5.	 Leave the document open.

Using the Mouse
If the location you want to navigate to is currently on the screen, you can simply 
position the mouse pointer and click. If the part of the document you want to view 
is currently not visible, you can use the scroll bars to navigate to that part of the 
document. The scroll bars enable you to quickly move to other areas of the document. 
If the zoom settings are set for page width (the default setting) or an even smaller 
percentage, the horizontal scroll bar will not appear because the entire width of the 
document is already visible.

If your mouse has a scroll wheel, you can use it to scroll vertically through a 
Word document. To scroll down, roll the wheel toward you, and to scroll up, roll the 
wheel away from you.

The position of the scroll box on the scroll bar helps you identify what part of 
the document you are viewing. As you drag the scroll box, a ScreenTip tells you 
what page you are viewing. As you learned in Lesson 11, when you scroll through 
a document, the insertion point does not move. If you scroll to a new part of the 
document and then want to reposition the insertion point on that page, simply click 
where you want to position the insertion point.

Browsing is another option for navigating through the document. When you 
browse, you focus on an object such as a page or a footnote. To browse, you use the 
three Browse buttons at the bottom of the vertical scroll bar shown in Figure 7–15.

Select Browse
Object button

Previous button

Next button

Figure 7–15  The Browse buttons on the vertical scroll bar

Extra for Experts

The Windows Control Panel pro-
vides options for changing mouse 
settings to fit your preferences. 
For example, you can change the 
appearance and size of the mouse 
pointer, or you can change how 
fast the mouse pointer moves 
around the screen. If your left 
hand is your dominant hand, you 
can change the settings so the 
right button is the primary button.
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Lesson 7 G etting Started with Word Essentials	

Step-by-Step 7.9
	 1.	 If necessary, open the Ruts document from your solution files.

	 2.	 Click the Zoom button on the View tab to open the Zoom dialog box, 

and click to change the percentage setting to 200%. Click OK. The 

horizontal scroll bar will appear. Drag the scroll box in the horizontal 

scroll bar at the bottom of the screen to the right side of the scroll bar.

	 3.	 Click the Page Width button in the Zoom group to reduce the 

magnification of the document.

	 4.	 Use the vertical scroll bar to move to the top of the document. Position 

the insertion point in front of the document title.

	 5.	 Click the Select Browse Object button at the bottom of the vertical scroll 

bar. The options shown in Figure 7–16 will appear.

Go To option Browse by Page
option

	 6.	 Move the mouse pointer over the options, and the name of the object will 

appear in the box. Notice that you can also access the Go To command 

in these options.

	 7.	 Click the Browse by Page option. The insertion point will move to the 

top of the second page.

	 8.	 Click the Previous Page button on the vertical scroll bar to move the 

insertion point back to page 1.

	 9.	 Click the Next Page button on the vertical scroll bar twice to move the 

insertion point to page 3.

	10.	 Leave the document open.

Using the Keyboard
If you have good keyboarding skills, learning keyboard shortcuts to move the 
insertion point can speed up your work. Using the keyboard shortcuts eliminates  
the need to move your hands away from the keyboard. You can use the arrow keys 
on the keyboard to move the insertion point one character at a time or one line at a 
time. If you need to move across several characters or lines, however, the keyboard 
shortcuts shown in Table 7–2 will make the task easier and quicker.

Figure 7–16 
Browse options

Extra for Experts

You can find a comprehensive list 
of keyboard shortcuts by searching 
for the keywords keyboard shortcuts 
in the Word Help dialog box.
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	 Module 2  Key Applications

To move the insertion point Press

Right one character right arrow

Left one character left arrow

Down one line down arrow

Up one line up arrow

To the end of a line End

To the beginning of a line Home

To the next screen Page Down

To the previous screen Page Up

To the next word Ctrl+right arrow

To the previous word Ctrl+left arrow

To the end of the document Ctrl+End

To the beginning of the document Ctrl+Home

Up one paragraph Ctrl+up arrow

Down one paragraph Ctrl+down arrow

table 7–2  Keyboard shortcuts for moving the insertion point

When navigating a multi-page document, the Go To command can also be 
very useful, because you can go directly to a specific page, line, or footnote in the 
document.

Step-by-Step 7.10
	 1.	 If necessary, open the Ruts document from your solution files.

	 2.	 Press Ctrl+Home to move the insertion point to the beginning of the 

document.

	 3.	 Press the down arrow twice to move the insertion point down two lines. 

Press the right arrow three times to move the insertion point three 

characters to the right.

	 4.	 Press End to move the insertion point to the end of the line.

	 5.	 Press and hold Ctrl and then press the left arrow to move the insertion 

point to the previous word.

	 6.	 Press Home to move the insertion point to the beginning of the line.

	 7.	 Press and hold Ctrl and then press the down arrow to move down one 

paragraph. Press and hold Ctrl and then press End to move the insertion 

point to the end of the document.
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Lesson 7 G etting Started with Word Essentials	

	 8.	 Press Page Down once to move down one screen.

	 9.	 Click the Find button arrow in the Editing group on the Home tab, as 

shown in Figure 7–17.

Find button
arrow

	10.	 Click Go To. The Go To tab in the Find and Replace dialog box shown 

in Figure 7–18 will appear. Under Go to what, select Page. In the Enter 

page number box, enter 2 and then click Go To. The insertion point is 

repositioned at the top of page 2. The information in the dialog box will 

adapt to the option you select.

	11.	 Enter 1 in the Enter page number box and click Go To to go to the first 

page. The dialog box will remain open, and you can drag the title bar to 

reposition it if you want to keep it open for future searches.

	12.	 Close the Find and Replace dialog box. The last option you chose in the 

Go to what box will appear when you open the dialog box again.

	13.	 Press and hold Ctrl and then press Page Down. The insertion point 

moves to the top of page 2.

	14.	 Close the document and the application. If prompted to save changes, 

click No.

Figure 7–17 
The Find button in the  
Editing group

Figure 7–18 
The Go To tab in the  
Find and Replace dialog box
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SUMMARY

Ethics in Technology

Watermarks
A watermark was originally an image embedded in a sheet of paper when the paper was produced to show 
the name or logo of the paper company. The term is also used to describe a very light image or text printed 
in the background of a document. Watermarks are no longer limited to paper; they are also added to digital 
files. The digital watermark identifies the owner of files and provides copyright protection. For example,  
corporations add their logo to the bottom corner of a video or slide show presentation. When used for  
photos, the watermark is often translucent and superimposed on the image. Although these types of water-
marks don’t prevent unlawful copying of images, video, and audio files, they show ownership and discourage 
illegal copying. Also, not all digital watermarks are visible to the human eye or audible to the human ear. 
Invisible watermarks are often embedded in the file and can be used to provide legal evidence of copyright 
infringement if digital media is copied illegally.

Another new technology, digital fingerprinting, provides information in the file about the originator or  
the purchaser. The fingerprint can be either visible or invisible. If the media is copied, the fingerprint is  
copied in the file, and the fingerprint can be traced back to the originator or purchaser. Software programs 
are designed to read digital watermarks and fingerprints. More new tools are on the horizon to protect the 
ownership of files and prevent people from stealing content.

In this lesson, you learned:

n	 New blank documents are created based on a template with 
default settings.

n	 There are many “behind the scenes” settings in Word which 
can be changed to meet your preferences.

n	 Word automatically wraps text to the next line when the line of 
text extends beyond the right margin.

n	 Word provides several options for viewing a document.

n	 You can use zoom options to increase or decrease the size of 
the text and graphics on the screen.

n	 To make editing easier, you can show the nonprinting 
characters, such as tab markers, blank spaces, page breaks, and 
paragraph markers.

n	 The click and type setting lets you position the insertion point 
in a blank area of a document.

n	 You can view thumbnails of the document pages to make it 
easier and faster to move through the document.

n	 You can also use the mouse, keyboard shortcuts, or the Go To 
command to move through a document quickly.

  Vocabulary Review
Define the following terms:

default settings
Normal.dotm template

toggle
word wrap
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 Rev iew Questions

TRUE / FALSE
Circle T if the statement is true or F if the statement is false.

T	 F	 1.	 All Word settings appear on the Ribbon or in dialog boxes.

T	 F	 2.	 As you enter a paragraph of text, you should press Enter to end each line at the right margin.

T	 F	 3.	 Word offers five different views for the document window.

T	 F	 4.	 The scroll bar includes buttons for browsing objects in the document.

T	 F	 5.	 The vertical and horizontal scroll bars are always visible for open documents.

MULTIPLE CHOICE
Select the best response for the following statements.

	 1.	 The  view allows you to quickly and easily reorganize the content.

A.	 Outline	 C.	 Full Screen Reading

B.	 Draft	 D.	 Print Layout

	 2.	 Nonprinting characters include .

A.	 paragraph markers, blank spaces, and page markers

B.	 paragraph markers, tab markers, and page markers

C.	 paragraph markers, blank spaces, tab markers, and page or section breaks

D.	 paragraph markers and page markers

	 3.	 When you  a document, you focus on an object such as a page or a footnote.

A.	 browse	 C.	 magnify

B.	 navigate	 D.	 scroll

	 4.	 You use the  options to increase and decrease the size of text and graphics on the screen.

A.	 document view	 C.	 zoom

B.	 scroll bar	 D.	 Go To

	 5.	 To move the insertion point to the top of the document, press .

A.	 Ctrl+up arrow	 C.	 Ctrl+Home

B.	 Shift+up arrow	 D.	 Ctrl+up arrow

FILL IN THE BLANK
Complete the following sentences by writing the correct word or words in the blanks provided.

	 1.	 Preset options already in place in a new document are called .

	 2.	 The  feature automatically moves text to the next line when you reach the right margin.

	 3.	 The  feature enables you to position the insertion point in a blank area of the document.

	 4.	 The  is a file containing default styles and customizations that determine the structure and page layout of a 
document.

	 5.	 When you  a setting, you are alternating between the off and on states by repeating a procedure, such as clicking a 
button.
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 p rojects

Project 7–1
	 1.	 If necessary, start Word. If Word is already open, create a new 

blank document.

	 2.	 Enter the following two paragraphs.

Almost everyone knows about the San Andreas 
Fault in California. Shifting along this 
fault line resulted in numerous damaging 
earthquakes throughout the twentieth 
century.

Relatively unknown by comparison, the 
New Madrid Fault in the central United 
States caused three of the most powerful 
earthquakes in U.S. history in the 
nineteenth century. One earthquake along 
this fault line was so powerful that it 
caused the Mississippi River to change 
course. Damage from the earthquake was 
reported as far away as Charleston, South 
Carolina, and Washington, DC.

	 3.	 Save the document as Fault.

	 4.	 Switch to Full Screen Reading view.

	 5.	 Position the insertion point at the beginning of the document 
and enter Someone Else’s Fault.

	 6.	 Press Enter twice to create extra space after the new line 
of text.

	 7.	 Save the changes and close Full Screen Reading view.

	 8.	 Change the zoom to 150% by changing the setting in the 
Percent box.

	 9.	 Close the document.

Project 7–2
	 1.	 Open Project7–2 from the data files.

	 2.	 Save the document as Interview Preparation.

	 3.	 Show the nonprinting characters in the document.

	 4.	 Scroll down to the middle of the document. Position the  
insertion point in the white space about two inches below the 
last question.

	 5.	 Choose one of the questions and enter your response to  
that question.

	 6.	 There should be at least four blank paragraphs between the 
last question and the response that you entered. If necessary, 
position the insertion point between the last question and your 
response and press Enter to add more blank lines.

	 7.	 Save your changes and close the document.

Project 7–3
	 1.	 Open Project7–3 from the data files.

	 2.	 Scroll to the middle of the document until you see the heading 
Similarities.

	 3.	 Use keyboard shortcuts to do the following:
a.	 move the insertion point to the end of the document
b.	 move the insertion point up one paragraph
c.	 move the insertion point to the beginning of the document

	 4.	 Use the Go To command to locate line 64, and then go to  
line 51. The insertion point should first be positioned near the 
heading Differences and then near the heading Similarities.

	 5.	 Show the Thumbnails pane and use the thumbnails to go to 
page 1. The first page in the document is a cover page, so it is 
numbered 0.

	 6.	 Browse the document by page until page 4 is the active page.

	 7.	 Close the document. If prompted to save changes, click No.
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  Critical Thinking

Activity 7–1
In this lesson you viewed documents in several different views. 
Which of these views do you prefer? Describe your preference and 
explain why.

Activity 7–2
When you open a Word document attached to an e-mail, the docu-
ment will most likely open in Full Screen Reading view as a result 
of default settings. Explore the Word Options and describe how 
you can change this setting so Word documents will open in Print 
Layout View when launched from an e-mail attachment.

 On line discovery
Open your Web browser and experiment changing the text size 
and zoom settings when you view Web pages. Compare changing 

the view of a Web page to changing the view of a Word document. 
Write a brief summary of the similarities you find.

  TEAMWORK PROJECT
Microsoft released the first version of Word for an IBM PC in 1983. 
The early versions of the Word software were created for MS-DOS, 
not Windows. Word made full use of the mouse, but few people used 
the mouse at this time. They usually accessed the commands by key-
strokes, and users often memorized the necessary keystrokes. So, 
keyboard shortcuts have been around for a long time. You learned 
several keyboard shortcuts in this lesson, but there are many more.

	 1.	 Choose a partner to find keyboard shortcuts for commands 
related to one of the following Word topics:
n	 Display and use windows
n	 Switch to another view/Full Screen Reading view
n	 Use dialog boxes
n	 Use the Open and Save As dialog boxes
n	 Create, view, and save documents

	 2.	 Explore the ScreenTips in Word and use the Word Help system 
to create a list of the commands and keyboard shortcuts for 
commands related to the topic.

	 3.	 Try each of the shortcuts described in your list to see if the 
shortcuts work on your computer.

	 4.	 Share your list with the class.
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